• Некоторые компульсии по поводу околокомпьютерных обсессий.

    Friday, June 27, 2014

    Определение расширения имени файла в 1С8

    На заметку.  Два способа - один через разбор строки, второй - через атрибуты объекта "файл".
    Первый способ будет и в 1С7 работать.
    Функция РасширениеФайла(ИмяФайла) 
     ПозТочки = 0;
     Расширение = ИмяФайла;
     Пока 1 = 1 Цикл
      ПозТочки  = Найти(Расширение , ".");   Если ПозТочки  = 0 Тогда
       Прервать; // больше нет точек, осталось расширение
      Иначе
       Расширение = Сред(Расширение , ПозТочки + 1);
          КонецЕсли;
     КонецЦикла;
     Возврат ?(Расширение = ИмяФайла, "", Расширение);
    КонецФункции 
    
    
    
    via 

    Второй способ. Чисто "восьмерочный".
    
    
    Файл = Новый Файл(СокрЛП(фИмяФайла)); 
    ИмяФайла = Файл.Имя; 
     Расширение =  Файл.Расширение; 
     ПолноеИмяФайла = Файл.ПолноеИмя; 
    
    
    Post a Comment